Items disappear from Weland -check out video

Discuss map ideas, techniques, and give help.

Items disappear from Weland -check out video

Post Mar 8th '14, 23:17

Hi,

I uploaded a video to youtube to show what is happening to Weland when I add 'items' to my map. Other than players and monsters, items disappear. Is there a way to fix this? Is there a weland update? I'm using v1.4.1 (which I think is the latest).

Help!

Here's the video:

https://www.youtube.com/watch?v=XOJdPQz ... e=youtu.be

Thanks for any help you can provide!
-p
User avatar

dustu

Post Mar 11th '14, 13:04

Hi,
Just a friendly bump. No ideas folks? Has anyone else seen this?
User avatar

dustu

Post Mar 13th '14, 20:48

I like your voice (lol), but I haven't had a problem like this. Sorry. If I see something like this, I'll holler.
Roses are rose red
Poems don't always make sense
Refridgerator
Dan
California

Post Mar 13th '14, 22:15

I see the same problem here. Mac OS X 10.9.2, Weland 1.4.1, Mono 3.2.7.
User avatar

Hopper

Post Mar 14th '14, 15:32

Do the items appear in Aleph One?
User avatar

treellama
Pittsburgh

Post Mar 14th '14, 22:07

Yes, it's a purely cosmetic bug. No icons are visible when I open the stock Ne Cede Malis, but the item panel comes up when I click on one by memory, and it momentarily shows up when I change the type. The icon disappears again when it's deselected.
User avatar

Hopper

Post Mar 15th '14, 11:44

That's exactly the behavior I'm seeing. :-)
User avatar

dustu

Post Mar 15th '14, 11:46

Dan wrote:I like your voice (lol), but I haven't had a problem like this. Sorry. If I see something like this, I'll holler.


LOL. Thanks Dan!
User avatar

dustu

Post Mar 22nd '14, 23:59

treellama wrote:Do the items appear in Aleph One?


What do you mean? We are talking about Weland aren't we? Am I missing something?
User avatar

dustu

Post Mar 23rd '14, 00:01

I have noticed an additional detail with this issue. When you zoom WAY in…and I mean ridiculously large, you see the icons for items appear in Weland. You have to use the mouse scroll to zoom and go somewhat slow but they eventually appear.

Unfortunately, the screen is so large it's really not helpful at all to design like this.

Given this discovery, is there a way to change my setup so that I can see icons without doing this?
User avatar

dustu

Post Mar 23rd '14, 00:20

dustu wrote:I have noticed an additional detail with this issue. When you zoom WAY in…and I mean ridiculously large, you see the icons for items appear in Weland. You have to use the mouse scroll to zoom and go somewhat slow but they eventually appear.

Nice catch, Paul. After playing with this, I found that the items appear for me when no vertices are in view. Once one of those red dots comes on screen, the items disappear again.
User avatar

Hopper

Post Mar 23rd '14, 00:23

Hopper wrote:
dustu wrote:I have noticed an additional detail with this issue. When you zoom WAY in…and I mean ridiculously large, you see the icons for items appear in Weland. You have to use the mouse scroll to zoom and go somewhat slow but they eventually appear.

Nice catch, Paul. After playing with this, I found that the items appear for me when no vertices are in view. Once one of those red dots comes on screen, the items disappear again.


Thanks! Question now is, how do we fix this? It's so annoying to design and not see item icons in Weland!
User avatar

dustu

Post Mar 23rd '14, 05:44

dustu wrote:Thanks! Question now is, how do we fix this? It's so annoying to design and not see item icons in Weland!


Well, you could try designing really big rooms with big polygons.
User avatar

PerseusSpartacus
Somewhere in the 19th Century...

Post Mar 23rd '14, 15:32

PerseusSpartacus wrote:
dustu wrote:Thanks! Question now is, how do we fix this? It's so annoying to design and not see item icons in Weland!


Well, you could try designing really big rooms with big polygons.


Are you being serious? ;-)

I already have 4 levels designed. I think that boat has sailed.

Any other suggestions?
User avatar

dustu

Post Mar 23rd '14, 17:00

Suggestion 1: Use Windows or Linux until the Mac version is working again.

Suggestion 2: Put that copy of MonoDevelop to use, and compile Weland yourself to see if the bug is still there. Then try to find and remove the code that draws vertices.

Not a suggestion: stop posting for the sake of posting. You bumped the thread after only three days: I check the forum about twice a week, and I don't think that's unusual for this community. You've asked "any ideas/suggestions?" five times in this thread, which is four times too many. Saying "it's so annoying" adds no new information, it just annoys the people in a position to help you.
User avatar

Hopper

Post Mar 23rd '14, 17:59

dustu wrote:Are you being serious? ;-)


Eh, it was just a thought. ^_^
User avatar

PerseusSpartacus
Somewhere in the 19th Century...

Post Mar 23rd '14, 19:02

Hopper wrote:Suggestion 1: Use Windows or Linux until the Mac version is working again.

Suggestion 2: Put that copy of MonoDevelop to use, and compile Weland yourself to see if the bug is still there. Then try to find and remove the code that draws vertices.

Not a suggestion: stop posting for the sake of posting. You bumped the thread after only three days: I check the forum about twice a week, and I don't think that's unusual for this community. You've asked "any ideas/suggestions?" five times in this thread, which is four times too many. Saying "it's so annoying" adds no new information, it just annoys the people in a position to help you.


1. Saying an issue is annoying is not a personal attack against anyone. It is annoying. Simply stating a fact.

2. About the bump: This issue has been asked by more than one person with very little in the way of an answer. It was asked about a long time ago with no real resolution.

3. I'm not a developer. I have no idea how to set up MonoDevelop. I am trying to do things as a non-developer and ultimately help others with the same bug.

4. Asking for suggestions more than once in a thread is a problem, why? I'm simply trying to resolve something. And my asking for more suggestions was in direct relation to suggestions - some of which did not help. Again, not being personal or impatient, just trying to resolve this.

5. I have a mac. I don't have a linux box.
User avatar

dustu

Post Mar 23rd '14, 19:04

PerseusSpartacus wrote:
dustu wrote:Are you being serious? ;-)


Eh, it was just a thought. ^_^


No worries. I just wasn't sure if you were serious. So I did try what you suggested…didn't make a difference though. :-) But thanks anyway for the suggestion. Every little bit helps.
User avatar

dustu

Post Mar 24th '14, 12:31

If you can't fix the problem yourself, it's not a good idea to annoy those who can :)

This is on my list to look at, but the Diablo III expansion comes out this week. So.
User avatar

treellama
Pittsburgh

Post Mar 24th '14, 19:45

treellama wrote:This is on my list to look at, but the Diablo III expansion comes out this week. So.


So that just means you have until midnight eastern time to fix it.
User avatar

Wrkncacnter

Post Mar 25th '14, 12:29

Wrkncacnter wrote:So that just means you have until midnight eastern time to fix it.

Well, that didn't happen!
User avatar

treellama
Pittsburgh

Post Mar 26th '14, 10:22

treellama wrote:Well!

rmph.png
patrick
末法

Post Mar 26th '14, 14:14

treellama wrote:If you can't fix the problem yourself, it's not a good idea to annoy those who can :)

This is on my list to look at, but the Diablo III expansion comes out this week. So.


Appreciate your efforts. Not trying to annoy anyone. I'm new, I spend a lot of time and effort on my own trying to figure things out and only come to the forum for things that I just can't figure out or resolve. I also try to provide useful information when I can. When I started this over a month ago, I had no clue how to use weland or visual mode, let alone create a level. All I know is I love Marathon and appreciate everyone's efforts here.

Now I am able to create basic levels with some bells and whistles and am having fun. That's all. I think Hopper read too much into my original reply to someone - not my intention to annoy. But can't fix development issues and I think sometimes people think you (meaning me) are a developer. I am not. I'm technically adept and comfortable with a lot, but in the end, I can't recompile apps or build code - not without a lot of help setting up my environment.

So I did attempt to install mlnodevelop and Xamarin on my mac. And I did notice that I got different errors when I tried to run the StairGenerator plugin (after I added paths to the proper assembly folders - see image). I also noticed that you see the icons that 'disappear' in Weland for items when you zoom way way in.

My point in all this is I do my best to help and as a non developer, It takes a huge amount of effort to figure things like this out. I guess my point is I'm not just some guy complaining on the forum. I do try to help and it's not easy to do so for me. Sorry if along the way I have somehow annoyed people. Again, not my intention. I hope you have a nice day and thanks in advance for your help! It is greatly appreciated.
Attachments
Screen Shot 2014-03-26 at 10.08.33 AM.jpg
User avatar

dustu

Post Mar 27th '14, 07:29

Sometimes when you bump a thread, you come off as impatient. I suspect that's what was perceived in this case. When a topic is still highly visible, e.g. on the front page, it's hard to justify bumping it.

Please don't construe a lack of response as meaning you're being ignored. I've been reading every post in this thread. But as a non-developer, I haven't posted anything, since the gist of any response would be "Gee, I can appreciate how that's a problem, but I don't know anything that would help." Other readers are likely in the same camp.
User avatar

Crater Creator

Post May 26th '14, 13:16

Weland 1.4.1 is working just fine with the latest stable version of Mono (2.10.11) in OS X Mavericks 10.9.2 here. No problems displaying icons.

It's also working fine for me with the beta version of Mono 3.4.0. Maybe Mono 3.2 was a bad release?
User avatar

treellama
Pittsburgh

Next

Return to Mapping



Who is online

Users browsing this forum: No registered users

cron