Help - My Enemy won't kill others;

Discuss map ideas, techniques, and give help.

Post Jun 29th '10, 05:41

So I am trying to make a kamikaze enemy using custom shapes. I tried the basics, but they did not seem to work (clicking the kamikaze flag, setting enemy types, shrapnel etc.). I copied the assimilated Bob physics for a base and tried again, and still he could not preform his sacrilegious duties.

The enemy will run up to someone, either a BOB, or the player, explode [playings its death animation], and then it will promptly disappear, dealing no damage to the player or the enemy. {See Video}[attachment=3929:Sequence_01_1.mpg]

I'm not sure how else to proceed. I've spent a lot of time trying to debug this but am not sure what else to do. I thought it was an origin issue, but compared to the assimilated Bobs, it should be adequate. Screenshots and video provided. (The burning Bob is a placeholder)


All and any advice would be appreciated.

P.S. Is there anyway to change sequence frames in Shapesfusion without having to click 1000s of times?

[attachment=3927:Anvil1.PNG][attachment=3930:Anvil3.PNG]
Attachments
Anvil3.PNG
Anvil3.PNG (424.03 KiB) Viewed 386 times

[The extension mpg has been deactivated and can no longer be displayed.]

Anvil1.PNG
Anvil1.PNG (505.08 KiB) Viewed 390 times
Last edited by Zott on Jun 29th '10, 05:54, edited 1 time in total.
Video Gamer Blog (With some articles by me!)

Look at Him Go, Weeee
User avatar

Zott
Earth

Post Jun 29th '10, 08:16

You said you copied the assimilated bobs, but two things are off. Namely the damage type and its hard dead sequence. Try to change the damagetype to explosion and give it a hard dead sequence (change -1 to something else).
User avatar

goran

Post Jun 29th '10, 15:14

Originally it was set to explosion, but it didn't work so I tried Crushing, no difference. I tried Hard Dead with a sequence number, but it still doesn't work.

I'm guessing that the explosion is "under the floor" and so is not hitting anybody, but I'm confident that I put the origins at the bottom of the explosion so they would stick out of the ground. I've set the enemy to fly, and watched the explosion drop as the enemy dies, so I'm not sure where the damage is hitting. The explosion range is very great, so...?
Last edited by Zott on Jun 29th '10, 15:25, edited 1 time in total.
Video Gamer Blog (With some articles by me!)

Look at Him Go, Weeee
User avatar

Zott
Earth

Post Jun 29th '10, 15:51

I don't think it has to do with the origins. My guess is that the explosion is not even triggered.

I once had a similar problem with a kamikazi monster and the
problem went away when I changed the physical constants.
Here's some troubleshooting I'd do:

If your alien flies, check hard delayed death.
Set speed to 50.
Set height to 1024
Set radius to 512

Can't say if it will work for you too, but it is worth a shot.
Last edited by goran on Jun 29th '10, 16:09, edited 1 time in total.
User avatar

goran

Post Jun 29th '10, 19:53

Well, I left the speed alone so that wasn't a problem. But using the rest of your settings, the kamikaze effect is now triggered! Perhaps it had to do with there being no soft death animation for my monster like the BOB has, thus the necessity of the Delayed Hard Death setting. Yet the radius and height were also required.

Regardless, thankyou for your help!
[attachment=3935:Psychona...01_32_20.png]
Attachments
Psychonauts_2010_03_24_20_01_32_20.png
Psychonauts_2010_03_24_20_01_32_20.png (1.1 MiB) Viewed 382 times
Video Gamer Blog (With some articles by me!)

Look at Him Go, Weeee
User avatar

Zott
Earth


Return to Mapping



Who is online

Users browsing this forum: No registered users