Marathon crashes when it changes levels

Pfhorums news can be found here. Have a question or suggestion for the Pfhorums? Ask it here.

Marathon crashes when it changes levels

Post Jul 17th '14, 22:17

Hello guys!

I've always been a huge fan of the Marathon games for years and thought it was time to revisit them.

I'd like a little help from you if possible. I've just beaten Marathon 1 and am starting Marathon 2, but both games have crashed significantly while changing levels. In the first game, at least the game crashed, but then, I tried again and it worked, I was playing the next level. But now, in Marathon 2, I'm at the end of the third level, getting myself to the terminal that leads to the fourth level and the screen goes black! I hear the sound which accompanies the title of the next chapter, Volunteers, I guess, but the screen is black and it stays like that for a couple of second and the game crashes. I've tried like 5 or 6 times already and the game always crashes at that part.

I'm using a MacBook Intel Core i7 and am playing the game with the classic graphics (no OpenGL or anything like that) and 1280x800 pixel resolution. Latest Aleph One version as far as I'm concerned.

Anything that I might be doing wrong? Could you guys help me? I'd appreciate it. :D
alansan

Post Jul 18th '14, 04:21

I really wouldn't recommend using the Software renderer on Mac OS X. Apple has been removing or breaking a lot of the drawing APIs it uses, so I'm not surprised it's causing problems on newer hardware like yours. You don't have to abandon the classic look at all: this thread lists the settings to use:

TheMoonChef wrote:At the main menu, go the Preferences and then to Graphics. Here, change the renderer to OpenGl (Classic). The other settings on the screen do not matter, though you can change the resolution to 640x480 if you want to be really retro. Now click the Rendering Options icon. Here, untick all the boxes toward the top except for Colour Effects and Static Effect. Also turn off Full-screen Anti-Aliasing and turn down the Anisotropic Filtering all the way (I recommend you turn on VSync to avoid image tearing). Now you go to Advanced, and put all Texture Filtering options to None, and Apply!
User avatar

Hopper


Return to The Pfhorums



Who is online

Users browsing this forum: No registered users

cron