display is huge, way past full screen

Have a question, suggestion, or comment about Aleph One's features and functionality (Lua, MML, the engine itself, etc)? Post such topics here.

display is huge, way past full screen

Post Feb 6th '19, 16:43

I am trying to get Aleph One running on a new computer, and am encountering some strange behavior.

When I start it, it's like I'm viewing the middle of the left part of the game's home screen, in full screen. That is, the actual physical screen is full, but everything's twice as big, and shoved off the top, bottom, and right edges. It stays this way after starting a game.

Depending on how you look at it, the cursor and cursor position, are unaffected. I can't move past the edge of the screen, but I have to guess where to click to activate any button except for the credits.

Even stranger, I think, this only happens with the original trilogy. It works fine with the scenarios I have: Rubicon, Phoenix, Evil, RED, and Eternal. Everything, including the trilogy, works fine on my own computer (Windows 8.1, 32-bit).

I have tried nuking everything, Aleph One and scenario folders both, and downloading fresh from lhowon.org, to no effect.

specs for the new computer:
Windows 10 (64-bit)
AMD Radeon HD 5830
AMD Phenom II X4 840T 2.9 GHz

One last bit of weird behavior, that I mention in case it's related: in game, when I look around, sometimes my guy keeps turning long after I've stopped moving the mouse. I guess this might be related to the sensitivity? That's freakishly high, too, but I've had THAT happen before.

Marathon is my absolute favorite game of all time, and I want him to play it (and so does he). His old computer, (WinXP) wouldn't even try to run it, either. Granted, that thing just all around sucked, but it does make this extra frustrating. I would REALLY appreciate help here, even if it's just tentative ideas that might not work.

Post Feb 7th '19, 05:50

donutguy640 wrote: ...even if it's just tentative ideas that might not work.

Probably you've already tried,
but in graphics setup set the screen size to a specific number and not "automatic".
Or, some setting in the computer's display; maybe in scale and layout or ease of access that don't show up in "normal" use.

The downloads use the 20150620 release for AlephOne, you might try downloading the 1.3b2 release and see if'n that works. It does for some and doesn't for some.

It's odd that Rubicon, Phoenix, Evil, RED, and Eternal, work and only the original trilogy doesn't.
I just play 'em; I don't know how they work.
User avatar


Post Feb 7th '19, 08:35

Are you sure you nuked your preferences? They're in a hidden directory, on Windows I think it's somewhere in something like %appdata
User avatar


Post Feb 7th '19, 18:02

Are you using the all-in-one apps for the trilogy? You might want to try downloading the game data separately and see if using the default A1 app works. It might not, but knowing whether it does will still tell us something relevant.
People should not be afraid of their governments. Governments should be afraid of their people.

“The trouble is that we have a bad habit, encouraged by pedants and sophisticates, of considering happiness as something rather stupid. Only pain is intellectual, only evil interesting. This is the treason of the artist: a refusal to admit the banality of evil and the terrible boredom of pain. If you can’t lick ’em, join ’em. If it hurts, repeat it. But to praise despair is to condemn delight, to embrace violence is to lose hold of everything else. We have almost lost hold; we can no longer describe happy man, nor make any celebration of joy.” —Ursula K. Le Guin, “The Ones Who Walk Away from Omelas”

Fool's Gold · Last.fm · Marathon Chronicles · Marathon Eternal 1.2 · YouTube Vidmaster’s Challenge
User avatar

The Man
Sarasota, FL

Post Feb 7th '19, 19:08

HelviusRufus wrote:The downloads use the 20150620 release for AlephOne, you might try downloading the 1.3b2 release and see if'n that works. It does for some and doesn't for some.

That worked, thank you VERY much!

Ravenshining, I apparently hadn't, I thought the preferences files were in the program folder, not the user data folder. It didn't work, but thank you for the suggestion all the same! Also, nice pic :D mmmmm, fire...

Return to Aleph One Discussion

Who is online

Users browsing this forum: No registered users