[Solved] Anyone got sound working on Ubuntu 14.04?

Have a question, suggestion, or comment about Aleph One's features and functionality (Lua, MML, the engine itself, etc)? Post such topics here.

[Solved] Anyone got sound working on Ubuntu 14.04?

Post Jul 7th '14, 09:05

In the past I've always been able to get Aleph One to run my machine on Ubuntu, but now on Ubuntu 14.04 it seems impossible. Any tips would be greatly appreciated. I'm running a Thinkpad W520 and while Aleph One runs only without sound, other applications do have sound.

What I've done so far (chronological order)
Code: Select all
./configure --prefix=/home/alephone/marathon2 && make && make install

Doesn't work, so I keep retrying while installing everything required by configure.

Code: Select all
sudo apt-get install libboost-all-dev libsdl1.2-dev libsdl-ttf2.0-dev libsdl-net1.2-dev libzzip-dev libvorbis-dev libavcodec-dev libavformat-dev libavutil-dev libswscale-dev

Compilation fails with errors, so I apply the patch here manually (by hand).

Now it compiles, I add the Marathon 2 files to the folder and start it:
Code: Select all
Aleph One Linux 2014-01-04 1.1

Original code by Bungie Software <http://www.bungie.com/>
Additional work by Loren Petrich, Chris Pruett, Rhys Hill et al.
TCP/IP networking by Woody Zenfell
Expat XML library by James Clark
SDL port by Christian Bauer <Christian.Bauer@uni-mainz.de>

This is free software with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
For details, see the file COPYING.

Built with network play enabled.

Built with Lua scripting enabled.
Segmentation fault (core dumped)

But running without sound (./alephone -s) works!

Other things I've tried:
- Installing the .deb from here (results in the same error).
- Installing every related package I can think of or that is mentioned here:
Code: Select all
sudo apt-get install libboost-all-dev libsdl1.2-dev libsdl-gfx1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-net1.2-dev libsdl-sound1.2-dev libsdl-ttf2.0-dev libspeexdsp-dev libzzip-dev libavcodec-dev libavformat-dev libavutil-dev libswscale-dev lua5.2 libvorbis-dev libsmpeg-dev

- Applying another patch from here

Any ideas?
Last edited by droptable on Jul 8th '14, 00:17, edited 1 time in total.

Post Jul 7th '14, 19:20

Try adding --disable-ffmpeg to the ./configure options and see if that helps.
User avatar


Post Jul 7th '14, 22:50

Hopper wrote:Try adding --disable-ffmpeg to the ./configure options and see if that helps.

Wow, that really worked. I don't need the movie recording stuff anyways.

Post Jul 7th '14, 23:29

Cool, glad it worked for you! FFmpeg and the libav fork both love to change their public APIs and break the older stuff, so it's hard for a small project like us to keep up with the version churn. Thanks much for working through the other patches, etc. to narrow down the problem, I really appreciate it.
User avatar


Return to Aleph One Discussion

Who is online

Users browsing this forum: No registered users