Used up all available RAM

Have a question, suggestion, or comment about Aleph One's features and functionality (Lua, MML, the engine itself, etc)? Post such topics here.

Used up all available RAM

Post Jan 16th '16, 17:56

Windows 7, 6GB RAM, AlephOne file version 0.2015.6.20

zErrorScreen.png (6.57 KiB) Viewed 1011 times

What does this mean and how do I fix it?

I get this usually on some individual maps, but today on Infinity.
I moved the entire folder contents to another name folder then moved it back
to Marathon Infinity and now it is working again.
I realize that I fixed it de facto but it is still there lurking and waiting.

No other programs were running at the time.
I tested Evil and Gray and both worked.

On windowed mode I checked memory and still had almost 5GB available so the message is a lie.
What causes it and is there a permanent cure?

I searched Pfhorums Aleph One discussion and Marathon discussion but found no hits on
the words used or available.
I just play 'em; I don't know how they work.
User avatar


Post Jan 16th '16, 19:58

When are you getting this error? When you first start up, when you begin a game, when you change levels...?

This error happens on some graphics failures, and several places when reading data from maps, Shapes, and other files. If you have a corrupted Shapes file, for instance, the engine could misread the size of some data, and try to set aside some enormous amount of memory all at once. It could even be a sign that your hard drive is starting to fail, so make sure you have good backups just in case.

I'd recommend you download a fresh copy of Infinity, and try that without any third-party plugins or maps installed. If that works fine, you can start adding things back to see if you can find a culprit. You can also check the log file, but it might not give us any clues.
User avatar


Post Jan 17th '16, 00:19

Thanks for the information, I'll go do some more investigations.

It was using the new game button. This is the only time ever on one of the Trilogy, Eternal, Tempus I, Phoenix,
Evil, Gray, etc., which seem to be a more extensive type of project package with title screens, etc.
instead of just a map pack. I've fired up Infinity several more times and it's worked just fine. I really like Ne Cede Malis and Arrival.

For example, I downloaded Infra Apogee because I wanted to see what the
tallest, etc., was all about. Using ctl-shft-new game on the last map produced the
error screen (and so does just new game button).
Also, Marathon C V7 (but the one I have has only 5 maps: 1 is Ribbons and 3 is Harpooning) ;
3 & 5 will play but 1,2,4 will produce the error screen.

I have an old Dell with XP and the same maps cause the same error screen on it. I usually use the Windows 7
machine because the Dell immediately exits when I try to use the map function. I first played through the Trilogy without the map function. Though I've now become accustomed to the map function.

I got these other maps just for sightseeing since they are unpopulated, but I found XBLA Survival
which will populate net maps with enemies.

And, truth be known, I've plenty yet to do in all the ones that work.
I just play 'em; I don't know how they work.
User avatar


Return to Aleph One Discussion

Who is online

Users browsing this forum: No registered users