Charon Doesn't Make Change Teleport issues

Have a question, suggestion, or comment about Aleph One's features and functionality (Lua, MML, the engine itself, etc)? Post such topics here.

Charon Doesn't Make Change Teleport issues

Post Nov 18th '16, 15:44

Hi all,

me and my bro downloaded the marathon install unmodified and are using Iron's co-op script.

We beat marathon 1 and are now on Charon Doesn't Make Change, however we have hit a snag.

Whenever either of us try teleporting using that one phor terminal that takes you to that unreachable place with the spht war terminals, the game crashes. We've teleported successfully in other levels. Maybe teleporting using terminals causes the problem.

Here are my specs:

Windows 7 Professional (6.1.7601) 64 bit service pack 1

Intel(R) HD Graphics 3000 with Driver version:

OpenGL (Classic)

We're using the Aleph One version that comes with the Marathon 2 install from this page.

The program crashes and I get a pop up that says:

Assertion Failed!

Program: ...
File: computer_interface.cpp
Line: 1162

Expression: !player->delay_before_teleport

For more information on how your program can cause an assertion
failure, see the C++ Visual documentation on asserts

(Press retry to debut the application - JIT must be enabled)

Post Dec 3rd '16, 10:20

I know this is late, but maybe you're still watching and these ideas may lead to something.

I scratch started the level and had no problems. Then I added the Co-Op script (There are two versions of it: I was using the 2.2.) and again didn't have any problems with teleporting but there is just one o me so that there are two of you may be the problem. It may be one player teleporting and the other not. Since you were able to do it in other levels, it may have something to do with this particular terminal, i.e. some parameter is misset.

This post is about some problems with the script and there is link to a modified version that may solve your problem too.

That's about the only help I can give; I really don't know about the mechanics of the games.
I just play 'em; I don't know how they work.
User avatar


Post Dec 3rd '16, 11:57

It's never too late!

Yeah I still have the same issue and it doesn't matter who teleports.

I'll try the other coop script and hopefully it'll work out.

Thanks for your help!

Post Dec 31st '16, 14:03

Yea so I tried the other co op script in the link you mentioned and still no dice.

Guess we'll have to play without the script I guess. Which sucks because we have gotten used it's very nice conveniences.

If anyone else has any other ideas I would be glad to hear them.

Post Jan 1st '17, 00:11

Evidently the Facilities Maintenance Division has been on holiday for quite a while and this blasted terminal is busted. Checking the online HUD manual, it says to hit the backslash \ key and look for the >_ prompt in the lower left of the HUD.
Then type in


(noticing that Players starts with uppercase and ends with s) replacing the first # with the SO number (0 or 1) and the second # with the destination polygon number.
A quick check of the Facilities Maintenance Division online catalog 7G shows that the desired destination is 222. Therefore


may work.
I just play 'em; I don't know how they work.
User avatar


Post Jan 2nd '17, 03:07

I don't mean to sound rude but... what are you talking about?

Is this lua script?

Post Jan 2nd '17, 05:02

Remember that this is basically cargo cult practice to me.

There is a console that can be accessed with the backslash key. When pressed, the command line with >_ prompt appears in the lower left of the HUD. Often it is kind of hard to see because of the background.
You can type in commands and they will be executed.
typing in Players[0]:teleport(222) then shows
hitting the enter key teleports you to polygon 222
which is the destination polygon the misbehavin terminal should teleport you to.
Notice that Players begins with uppercase and ends with s; Players uses brackets, teleport uses parentheses; there are no spaces.

Here is a topic that discusses using the console command line to solve a problem.

It is used mostly in development and should only be used in game play to overcome a specific issue such as the misbehavin terminal. In the above topic, I'm not sure that that is a good use of the console command in that it is being used to remedy a deficiency in gameplay.
In your case, I think it's a legitimate use and, in fact, perhaps the only way to continue the game.

This is speculation, but one of you is Players[0] and the other is Players[1] or similar since you are using the co-op script. I'd suggest one of you teleporting then setting a beacon or whatever the big green disk is called for the other player.
If that works but the terminal to get you out is also misbehavin, the return polygon is 260.

My comment was just a fanfic way of showing the console command that would take you where you want to go.

I hope this works, it's really a great game.
I just play 'em; I don't know how they work.
User avatar


Post Jan 2nd '17, 13:01

OOOhhh lol.

I thought you were being kindy fan ficcy there.

I didn't put 2 and 2 together and realize you were talking about a console command.

This is great news! I'll try it out today, thanks dude.

Post Jan 2nd '17, 19:50

Yea I tried the console commands and they failed.

So then we tried to restart from the previous level and try again and it worked normally.

Iono, I guess a random bug happened.

Thanks for all your help.

Post Jan 2nd '17, 21:25

Great. I'm glad you're on your way again.
Happy Carnage!
I just play 'em; I don't know how they work.
User avatar


Return to Aleph One Discussion

Who is online

Users browsing this forum: No registered users