Intel graphics breaks Background/Sky in OpenGL (Shader)

Have a question, suggestion, or comment about Aleph One's features and functionality (Lua, MML, the engine itself, etc)? Post such topics here.

Intel graphics breaks Background/Sky in OpenGL (Shader)

Post Jun 2nd '17, 09:02

When running in OpenGL (Shader) mode on my laptop's integrated Intel graphics, the background image doesn't render properly, it's just a solid colour with what look like pillars of other colours over it. Switching to OpenGL (Classic) or my GeForce card makes the background image display properly. I don't know if it's because the Intel card doesn't support the right shader model or what.

Windows 10 build 1703
Intel HD Graphics 4000 with driver 10.18.10.4425 and GeForce GT 630M with driver 382.33
A1 version 1.2.1, issue occurs and is fixed as outlined on all the scenarios I have.
Scoria

Post Jun 5th '17, 17:18

I really don't know much about these things but this topic might give you some leads.
That computer I was using is about 7 years old with W7.
I have another one with W10 and Intel HD Graphics 520 that shows the same backgrounds in Classic and Shader, at least on Durandal: Charon Doesn't Make Change, and Eternal: Hysterical Womb; the ones I checked.
I just play 'em; I don't know how they work.
User avatar

HelviusRufus

Post Jun 8th '17, 07:05

Thanks for the link.

Looking through that thread, it seems that it's just because Intel's drivers don't play nice with OpenGL.
Scoria

Post Nov 21st '17, 00:33

I have the same problem, except that my laptop has a geforce 610M. I don't know how to fix it. Please help.
User avatar

Procyon

Post Nov 21st '17, 06:46

Use the NVIDIA Control Panel to set the preferred graphics processor to the GeForce card in the Global Settings pane. That should force the program to use the GeForce and work properly. You may get horizontal lines flickering over the display, I've found that going into the graphics settings and switching the Full Scene Anti-Aliasing setting from 4x to 2x, then returning to the main menu to get it to apply, then going back and resetting it to 4x fixes that issue (though I do have to re-do it each time I start the program anew). That may not apply if you have the FSAA set differently.
Scoria

Post Nov 21st '17, 15:51

Thank you very much for your answer. It works! [MUp] I owe you a pfhor steak.
User avatar

Procyon


Return to Aleph One Discussion



Who is online

Users browsing this forum: No registered users