Aleph One 1.3b3

Have a question, suggestion, or comment about Aleph One's features and functionality (Lua, MML, the engine itself, etc)? Post such topics here.

Re: Aleph One 1.3b3

Post Apr 29th '19, 21:46

Well, there’s also the option of using (or adapting) the XBLA HUD, which uses the whole screen while keeping some of the game info onscreen. Unfortunately, the XBLA HUD leaves out some crucial info about the player’s inventory. One of these days I’ll write my own HUD.

I didn’t know about manually editing the preferences though. Huh. I’ll try that.

ETA: Yep, that works. Thanks.
“People should not be afraid of their governments. Governments should be afraid of their people.” —V, V for Vendetta (Alan Moore)

“The trouble is that we have a bad habit, encouraged by pedants and sophisticates, of considering happiness as something rather stupid. Only pain is intellectual, only evil interesting. This is the treason of the artist: a refusal to admit the banality of evil and the terrible boredom of pain. If you can’t lick ’em, join ’em. If it hurts, repeat it. But to praise despair is to condemn delight, to embrace violence is to lose hold of everything else. We have almost lost hold; we can no longer describe happy man, nor make any celebration of joy.” —Ursula K. Le Guin, “The Ones Who Walk Away from Omelas”

“If others had not been foolish, we should be so.” —William Blake, The Marriage of Heaven and Hell · Marathon Chronicles · Marathon Eternal 1.2 · Where Monsters Are in Dreams · YouTube Vidmaster’s Challenge
User avatar

The Man
Sarasota, FL

Post Jul 6th '19, 23:59

I hate to be "that guy" but I'm not sure what I'm looking at and nothing I've tried yet has fixed it. I can certainly say that maps didn't look like this in the previous version of AO. I could be wrong but it seems as though this only happens in maps with somewhat long viewing distances, as most maps look normal, but other times....well this happens.

EDIT: Okay I think I have found the issue. This odd warping seems to happen when an untextured wall is visible in screen view. IDK why this 'hall of mirrors' effect happens in this iteration of AO and not previous versions, but w/e.
Last edited by Flowers on Jul 16th '19, 06:03, edited 1 time in total.
User avatar


Post Jul 14th '19, 19:54

Are you supposed to be able to set Level.stash values from within the HUD? When I attempt to do something like this in Triggers.draw()
Code: Select all
Level.stash['test'] = "test"

It just prints out:
Code: Select all
[string "HUD Lua"]:82: no such index (lua_script.cpp:1118)

It can read the values out of the stash just fine, it only happens when trying to set a value. Not sure if that's supposed to be possible or not.
User avatar


Post Jul 14th '19, 21:08

So I've been having an issue where A1 stops receiving mouse clicks. A level will start just fine, but after a minute or so, mouse clicks stop registering. Then, after another minute or so, they start working again.

This only happens in windowed mode. I'll have to run some tests to see whether it does the same thing under a different window manager, and pinpoint what version started doing this, but people have been telling me I should report it for a while.

On a related note, A1 completely fails to recognise the 8th mouse button - or, rather, my 4th trackball button, but I guess my trackball uses button slots 4-7 to communicate movement and scrolling and then calls the 4th button button 8. Not a big issue for me, at the moment I'm binding it to Discord's push-to-talk, and I don't imagine many people use 4 button input devices and want all 4 buttons for A1, I'm just saying.

Oh, and while I'm here if anyone is interested, a month ago I submitted a PR that would restore M2's and M∞'s behaviour of playing music while the preferences dialogue and such are open, while still stopping it for the net lobby and films as Hopper pointed out was problematic with my earlier patch.
User avatar


Post Jul 15th '19, 20:20

I've been having lots of problems with mouse in SDL 2 versions as well. I've been through the new Aleph One code and it looks sound, so I think there are issues in SDL 2 itself. Try turning on/off raw mouse, see if that makes a difference.

Unfortunately I don't have the time to track down bugs in SDL 2.

I'm not a particular fan of the intro music patch myself. Plus I doubt anyone understands that code well enough to make changes without introducing bugs--including Hopper and myself. It all needs to be rewritten.
User avatar


Post Jul 17th '19, 10:22

At least, if that's the case, then someone else is bound to fix it at somepoint. SDL2 isn't that small a project and a lot of people depend on it. Haven't hit it myself, but then I personally can't play games in windowed mode. Drives me up a wall.
User avatar

Ledyard, CT

Post Jul 17th '19, 12:05

Wrkncacnter wrote:Are you supposed to be able to set Level.stash values from within the HUD?

User avatar


Post Jul 17th '19, 14:26

Do those issues with mouse input happen on all platforms? I have not noticed input glitches on MacOS, except for sometimes not being able to skip chapter screens; but nothing that affects gameplay.
User avatar



Return to Aleph One Discussion

Who is online

Users browsing this forum: No registered users