Weland Won't Open

Questions about the content creation procedure go here, including using Forge, Anvil, or other editors, or operating emulators like Basilisk II.

Weland Won't Open

Post Feb 24th '19, 05:55

I am running the latest .NET Framework, I've tried installing GTK#, I've tried installing Mono, I've tried previous versions of the release, Weland will do the little blue circly thing and then no window.
In fact, I redid all of that. I uninstalled Weland, I uninstalled GTK and Mono (can't do anything about NET). I ALSO tried a fresh clean install of weland on to a different machine, and it would still not boot.
I have shared this experience with other players attempting to make maps recently. Are there some suggestions, people could give me as how to solve this issue?
User avatar

Flippant Sol

Post Feb 25th '19, 16:36

Did you try gtk-sharp-2.12.20?
Version 2.12.20 is the only way I'm able to use weland.
I'm running windows 10.
Qweasy908

Post Feb 26th '19, 03:18

Flippant Sol wrote:I am running the latest .NET Framework, I've tried installing GTK#, I've tried installing Mono, I've tried previous versions of the release, Weland will do the little blue circly thing and then no window.
In fact, I redid all of that. I uninstalled Weland, I uninstalled GTK and Mono (can't do anything about NET). I ALSO tried a fresh clean install of weland on to a different machine, and it would still not boot.
I have shared this experience with other players attempting to make maps recently. Are there some suggestions, people could give me as how to solve this issue?

I was using GTK 2.12.21 for a long time with no issues. However my SSD recently failed and I lost pretty much everything. When I went to reinstall Weland afterwards I've had issues with it since. I've tried 2.12.45, 2.12.21, and 2.12.20 and I seem to have problems with all of them. Weland will open but it will often crash after a few lines are drawn (a problem I had back in 2017 and fixed by using GTK 2.12.21). It's definitely frustrating. I wonder if mac users have an easier time.
User avatar

Flowers

Post May 21st '19, 20:39

I have found the solution. As previously stated by Flowers and Qweasy908, Weland likes a very specific version of GTK# which is version 2.12.20. However, that version is not available on mono's official archives as of now because 2.12.45 is the current version, I guess. So I did some googling and I found a backed up version of it on npackd.org. https://www.npackd.org/p/gtksharp/2.12.20
this link is malware-safe
User avatar

Flippant Sol


Return to Editors, Emulation, Etcetera



Who is online

Users browsing this forum: No registered users

cron