Visual Mode Texture Selection

Questions about the content creation procedure go here, including using Forge, Anvil, or other editors, or operating emulators like Basilisk II.

Visual Mode Texture Selection

Post Apr 17th '13, 18:03

Q: How do I switch textures?
A: In texture mode, hold down the mic key and press prev or next weapon

I usually adjust to programs fast: Visual Mode is totally eluding me.

I have the .s save function working and the main question now is how to switch textures. The above does not work, as when pressing the microphone key (`), the option to place a texture is gone - no crosshairs.

The interface is not clear to me yet: and the move tool seems to hyperspace the viewer back to the same location? Forge used to have a fly function: what does this move in place do?

Will keep trying and reading threads. Any tips to further instructions would help. I am now on an Extended Keyboard with A1 default key configuration. Thanks!

Post Apr 17th '13, 19:55

The current texture has a green box around it. Hold the mic key and look at the bottom of the screen. The triggers change textures within a collection, prev/next weapon change the collection. Then let off the mic and apply the texture you picked. Hold mic, choose, release mic, paint. Repeat.
User avatar


Post Apr 18th '13, 19:07

Sounds like there is supposed to be a texture collection at the bottom of the screen in Visual Mode. I have no texture collection icons at bottom of the screen. I do have the six text categories at top screen that are rotated by action, mic, and next/previous weapons keys. I have tried all the screen sizes and don't see a bottom screen collection.

If that's it, a texture collection would make this happen.

I am running Mac OS X Lion 10.7.4 on a 2.7 Ghz iMac. Visual Mode .lua and .mml both on (May 2010 versions)

Post Apr 18th '13, 19:27

I ran my data pack in the Aleph One Marathon Infinity and the texture panel is at bottom. There must be an incompatibility with Aleph One 1.0.2 and my system or I have conflicting options. The program makes total sense now with that collection as I was starting to get the brain damage trying to figure out visual mode. Thanks!!!

Post Apr 18th '13, 19:33

You need to disable the XBLA HUD plugin in Preferences -> Environment -> Plugins to see the texture palette.
User avatar


Post Apr 20th '13, 04:30

XLBA Hud is disabled and have been doing texture work, getting used to interface. I have seen two maps with problems: one the texture menu at bottom turned black. Could this be a transparent mode or a corruption? Another map's landscape texture became the only texture available, and when applied, it was a repeating non-landscape texture. Are these corruptions? Should maps be moved from application support into the data folder for the game engine? There is an instruction in the Visual Mode read me:
Since Aleph One is a little sloppy about clearing out the data in
levels it exports, I recommend opening and resaving in Forge when
finished texturing.
Is that really necessary?

Post Apr 20th '13, 05:09

glue wrote:Is that really necessary?

Well, I've never done that, and my maps are excellent.
User avatar


Post Apr 20th '13, 20:52

Several maps have stuck texture menus (can't select textures) or turn black with the only option but to apply black textures or landscapes that are small repeating patterns instead of diorama. If I nuke the textures, everything is back to normal. But I have to start over.

I am slowly getting back to good mapmaking again, too. Almost, except for this issue. There's a lot more possibilities to develop scenarios with all the updates.

Post Apr 22nd '13, 05:02

Saving a new map every time I work: that seems to be keeping the maps without corruption, if it was a corruption issue.

Return to Editors, Emulation, Etcetera

Who is online

Users browsing this forum: No registered users