HD Player Models (I think this will end up belonging here)

Questions about the content creation procedure go here, including using Forge, Anvil, or other editors, or operating emulators like Basilisk II.

Re: HD Player Models (I think this will end up belonging her

Post Aug 20th '13, 02:49

That fixed it, only I had to turn off the background reconstruction, which I had on before, and seemed to make it worse, which makes no sense as the reconstruction color I had is white. I simply don't how it works... Thank-you for your help! Aorta has been a really useful program. Thanks for making it [MSmile]
User avatar

herecomethej2000
Ledyard, CT

Post Aug 20th '13, 12:31

Background reconstruction is for when the transparent color has bled into the non-transparent colors. This can happen when you scale a large image down, for instance. You could pick the transparent color (in your case, black) to try to fix it. But it's not necessary on those sprites, they are pretty clean.

Hopper uploaded all the Freeverse textures here: http://whpress.com/aleph/MarathonTexturesAll.zip

I looked through and didn't see anything higher-res, but the player sprites and wall textures in there are PNG. Dig around and see what you can find.
User avatar

treellama
Pittsburgh

Post Aug 20th '13, 15:31

Hey will do, and thanks!

If we ever attempt to redo them with better contrast, we can always use those ones on principle if no other real reason. :)

Thanks for the reconstruction info that does sound useful and makes sense why i would get the result I did.
User avatar

herecomethej2000
Ledyard, CT

Post Aug 21st '13, 00:50

Out of curiosity, did any of that fix the holes in the suppressor?
User avatar

Spurious Interrupt

Post Aug 21st '13, 02:52

Dunno, if you could take a look. I haven't been able to reproduce it
User avatar

herecomethej2000
Ledyard, CT

Post Aug 31st '13, 06:57

Do I understand correctly from the early parts of this thread that there are HD player models (the actual 3D geometry) available somewhere on SourceForge? Those could come in really handy for the Eternal weapons project I'm getting restarted right now. If I do understand, could someone please give some more specific directions, because starting from marathon.sourceforge.net I'm not finding any clear place to look for things like that.
User avatar

Pfhorrest
California

Post Aug 31st '13, 13:43

As far as I know, the 3D models that generated the XBLA player sprites have not been released.
User avatar

goran

Post Sep 1st '13, 13:13

Unfortunately no, there are no 3d models available from freeverse. (Or this could have been easier) The one of the smg you saw was created specifically by Spurious which we needed to get the proper angles for the 2d images. and the rest is simple Photoshop err.. Gimp superimposed on the AR 2d sprites, which came out with really good results.
User avatar

herecomethej2000
Ledyard, CT

Post Sep 1st '13, 14:06

Hey treellama thank-you for posting those sprite files, I did find a use after all. I used them to systematically replace all my pngs/dds to png conversions I had taken from the XBLA plugin. The XBLA set does suffer from some compression artifacts particularly with the drones and fighters, and all the sprites had been compressed to one degree or another. I also uncovered a few oddities: enforcer apparently has a color-table 2 that was not in the XBLA plugin (any of them), cyborg has clut 2 and 3 which wern't in any XBLA plugin, and Spht color table 1 on those original artwork files appear to be modeled after the the M1 sprites, which is odd as the color table 2 is back to the M2/Minf one. (wont be using that but It could be useful to someone sometime) But it did have the missing part of the Spht bolt clut1 that also wasn't in the XBLA plugin
User avatar

herecomethej2000
Ledyard, CT

Post Sep 1st '13, 16:36

The Marathon compiler is present in the latest version of the plugin.
User avatar

treellama
Pittsburgh

Post Sep 1st '13, 23:47

Ah I see, is the latest one the one included with m2? I don't think I'd use it. It's not in m infinity, and I like consistency with the other color-tables. :)
User avatar

herecomethej2000
Ledyard, CT

Post Sep 4th '13, 00:36

I would like to congrats you on completing this project. I respect version 1.22 very much. However, I have a complaint, and I haven't even play-tested it yet.

I want you to take a gander at this image. This is what happened when I extracted the file folder to my desktop:
WTF.jpg

Notice anything? How about the 4,999 items for a 15 minute extraction? I think I'm starting to miss the heavily compressed images already. If you thought that was bad, look at this one...
BRAIN EXPLODED.jpg

All I wanted was to decrypt the data, Now I won't be able to play-test this plugin until after school ends tomorrow.
User avatar

A Huge Pfhan
Sol

Post Sep 4th '13, 00:44

something is clearly wrong with your computer, It only takes me a couple of minutes and mine is over 6 years old. Why don't you try restarting or using another package manager like 7zip

@treellama
Why is it in windows a1 cant read plugins from zip files directly? I thought you use to be able too, but now it crashes. You can certainly still do on mac.
User avatar

herecomethej2000
Ledyard, CT

Post Sep 4th '13, 02:25

herecomethej2000 wrote:@treellama
Why is it in windows a1 cant read plugins from zip files directly?

It can.
User avatar

treellama
Pittsburgh

Post Sep 4th '13, 14:47

I guess your right. The problem is with large zip files (My Monsters HD plugin for instance). It worked fine on my mac. A1 trys to open up, the cursor spins but doesn't launch. It hangs in the process tree and has to be ended in the task manager. Unfortunately there is nothing in the error log, or if I try to launch the .exe in the console.
User avatar

herecomethej2000
Ledyard, CT

Post Sep 4th '13, 15:13

herecomethej2000 wrote:I guess your right. The problem is with large zip files (My Monsters HD plugin for instance). It worked fine on my mac. A1 trys to open up, the cursor spins but doesn't launch. It hangs in the process tree and has to be ended in the task manager. Unfortunately there is nothing in the error log, or if I try to launch the .exe in the console.

Is this with 1.0.2 or 1.1b3? Can you try it with the other one? I believe they use different versions of zziplib.
User avatar

treellama
Pittsburgh

Post Sep 4th '13, 20:24

Neither will work I'm afraid, very curious that nothing shows up on the alephone.log. It would be nice to know why it fails.
User avatar

herecomethej2000
Ledyard, CT

Post Oct 4th '13, 17:30

I was able to load the Monsters HD plugin with 1.1b3, but it took a long time (on the order of minutes!). Clearly not usable, but it doesn't fail, which is why you don't see anything in the log.

I'll see if I can improve it for the final 1.1 release.
User avatar

treellama
Pittsburgh

Post Oct 4th '13, 20:32

treellama wrote:I was able to load the Monsters HD plugin with 1.1b3, but it took a long time (on the order of minutes!).

We're talking kilohertz of speed here.
User avatar

Wrkncacnter

Post Oct 5th '13, 15:49

User avatar

irons
(.Y.)

Previous

Return to Editors, Emulation, Etcetera



Who is online

Users browsing this forum: No registered users

cron