Pitch black landscapes/textures

Questions about the content creation procedure go here, including using Forge, Anvil, or other editors, or operating emulators like Basilisk II.

Pitch black landscapes/textures

Post Mar 1st '14, 16:14

Good day gentlemen!

I'm making my first A1 scenario now, and it seems like I've ran into roadblocks already in the beginning... I've searched the internet and the Pfhroums for this during the last 2-3 hours, but haven't found an answer :( So, I'm using ShapeFusion 0.6 and trying to make a custom skybox (replacement texture for Landscape 1, using Infinity Shapes file as a source). It looks alright in ShapeFusion (True Color version), and I have imported the custom color map and such, but when I'm using the Visual Mode Lua (again, under Infinity), the landscape is completely black! I'm completely puzzled; not to mention I've spent a lot of time trying to figure out what's wrong, uploading the image in different formats, etc. :( Can you please advise on what may be the issue? I fear I might run into the same issue altered textures in Shapes :wacko:

Here's the Shapes file I've modified: https://www.dropbox.com/s/nzgtfs0kl1sec0n/Shapes.zip

Thank you very much in advance!!!
User avatar

EinhanderZwei
Nikolaev, Ukraine

Post Mar 1st '14, 19:45

Never seen this happen.
Instead of using indexed color, try RGB color?

I'll try seeing what I can do with this in my spare time.
Roses are rose red
Poems don't always make sense
Refridgerator
Dan
California

Post Mar 1st '14, 20:42

Tried inserting a fullblown RGB-encoded PNG image of the same size (540x1024), and now Aleph One crashes when using OpenGL Classic or Software mode, and with OpenGL Shader, all the skies are displayed in plain color, even the ones I haven't touched!

I feel like I'm mentally challenged... :(
User avatar

EinhanderZwei
Nikolaev, Ukraine

Post Mar 1st '14, 20:59

Well, I can duplicate your results, but I can't offer a solution. [MErr]
User avatar

Crater Creator

Post Mar 1st '14, 22:04

Oh my... :( I'm so frustrated because it's such a basic thing... everybody's building their custom Shapes files; I've opened the Shapes file for Eternal, and it doesn't even have to bother with color schemes and stuff - it has high-res skyboxes already inside! I must be doing something wrong :( I just want to replace the skyboxes and textures inside the Shapes file, and without any warnings or error messages, Aleph One just doesn't even do anything... I SO hate it when that happens :'(
User avatar

EinhanderZwei
Nikolaev, Ukraine

Post Mar 2nd '14, 04:42

EinhanderZwei wrote:Tried inserting a fullblown RGB-encoded PNG image of the same size (540x1024), and now Aleph One crashes when using OpenGL Classic or Software mode, and with OpenGL Shader, all the skies are displayed in plain color, even the ones I haven't touched!

I feel like I'm mentally challenged... :(


Crater Creator wrote:Well, I can duplicate your results, but I can't offer a solution. [MErr]


EinhanderZwei wrote:Oh my... :( I'm so frustrated because it's such a basic thing... everybody's building their custom Shapes files; I've opened the Shapes file for Eternal, and it doesn't even have to bother with color schemes and stuff - it has high-res skyboxes already inside! I must be doing something wrong :( I just want to replace the skyboxes and textures inside the Shapes file, and without any warnings or error messages, Aleph One just doesn't even do anything... I SO hate it when that happens :'(


barr barr barr, I was playing around with it, but I also can't seem to get it working. Hmph. Just saying, but I noticed I don't have this problem with much else; only the skyboxes seem to have a major problem. Weapon in hand works. Control panels also seem to work (for now?).

Yeah, Aleph One not giving ANY hints is kind of annoying.
Roses are rose red
Poems don't always make sense
Refridgerator
Dan
California

Post Mar 2nd '14, 05:37

It certainly seems to me like the landscapes are the weirdest and most finicky part of the Shapes file. This sort of thing really doesn't surprise me - I may even have encountered it once before, though I'm not sure quite what I did.
User avatar

PerseusSpartacus
Somewhere in the 19th Century...

Post Mar 2nd '14, 19:04

Welp, the only help i can give is the relevant part of the crash log:

Code: Select all
 file's resource reference list corrupt (/Users/ghs/aleph/trunk/PBProjects/../Source_Files/Files/resource_manager.cpp:276)
while opening resource file [PATH/shapes.shpA](/Users/ghs/aleph/trunk/PBProjects/../Source_Files/Files/resource_manager.cpp:338)
  file's resource reference list corrupt (/Users/ghs/aleph/trunk/PBProjects/../Source_Files/Files/resource_manager.cpp:276)
Unhandled exception: vector::_M_fill_insert (/Users/ghs/aleph/trunk/PBProjects/../Source_Files/shell.cpp:375)


If I had Anvil set up I'd see if maybe it's partially an issue with ShapeFusion, but I remember having similar issues even using the classic tools. Sadly, I don't remember how I overcame them. For what it's worth, I've tried using your new bitmap with an existing colour table, and your colour table with the existing bitmaps. Both yield the same error.
User avatar

$lave

Post Mar 3rd '14, 10:43

I'm no expert in this, but it looks like your color table is invalid. You should have gotten a message from ShapeFusion telling you this when you imported it.
User avatar

Ares Ex Machina

Post Mar 3rd '14, 14:13

Thank you very much for the feedback guys! I'm glad (in a sort of weird way) that this issue is not my personal delusion, but something well-known that has occurred to other people, too... I really want to get into Aleph One modding, since Marathon trilogy is my all-time favorite gaming franchise, but so far it seems so hostile towards me compared to id Tech engines and their derivatives!

I'm no expert in this, but it looks like your color table is invalid. You should have gotten a message from ShapeFusion telling you this when you imported it.

That's true, I have experimented with color tables as well. Some of them did return error messages, some didn't (the one in the file I've linked did not, IIRC). And again, compared to Eternal X - it seems to have the default color tables assigned, but actual True Color skyboxes embedded within its Shapes. So weird... :wacko:
User avatar

EinhanderZwei
Nikolaev, Ukraine

Post Mar 3rd '14, 16:33

There's always the possibility that there's a bug in ShapeFusion. I doubt many people use built-in landscape replacements, when the external ones can be high resolution and full color.
User avatar

treellama
Pittsburgh

Post Mar 3rd '14, 16:43

treellama wrote:There's always the possibility that there's a bug in ShapeFusion. I doubt many people use built-in landscape replacements, when the external ones can be high resolution and full color.


I completely agree with you, but if I use default Shapes and do everything via external textures, the people who download it would be left with a useless set of default Infinity resources that won't be used ingame. I just want everything optimized and minimized!
User avatar

EinhanderZwei
Nikolaev, Ukraine

Post Mar 4th '14, 01:16

EinhanderZwei wrote:
treellama wrote:There's always the possibility that there's a bug in ShapeFusion. I doubt many people use built-in landscape replacements, when the external ones can be high resolution and full color.


I completely agree with you, but if I use default Shapes and do everything via external textures, the people who download it would be left with a useless set of default Infinity resources that won't be used ingame. I just want everything optimized and minimized!


Welp, if it is ShapesFusion's fault, then I'm not sure there's another option than using external textures. But I don't know.
Roses are rose red
Poems don't always make sense
Refridgerator
Dan
California

Post Mar 5th '14, 09:16

EinhanderZwei wrote:I really want to get into Aleph One modding, since Marathon trilogy is my all-time favorite gaming franchise, but so far it seems so hostile towards me compared to id Tech engines and their derivatives!

Count the devs from each community and compare. There's probably a good reason.
User avatar

Ares Ex Machina

Post Mar 5th '14, 18:46

Ares Ex Machina wrote:
EinhanderZwei wrote:I really want to get into Aleph One modding, since Marathon trilogy is my all-time favorite gaming franchise, but so far it seems so hostile towards me compared to id Tech engines and their derivatives!

Count the devs from each community and compare. There's probably a good reason.


I know, I know... :( My point is that I'm so frustrated over no ability to perform such a primitive thing that everyone has done successfully...
User avatar

EinhanderZwei
Nikolaev, Ukraine

Post Mar 6th '14, 03:22

If the problem is with ShapeFusion, you should try making your modification in Anvil, if possible.
User avatar

Crater Creator

Post Mar 7th '14, 03:55

This is a ShapeFusion bug. It sets a flag wrong when pasting in landscapes. You were the first to report the bug, because as Treellama said, nearly everyone uses external textures which aren't limited to 256 colors.

I don't see any way to get around the bug in the current version of ShapeFusion. Use Anvil if you can, or wait until a new ShapeFusion comes out (which might take a while), or use an external texture.
User avatar

Hopper

Post Mar 7th '14, 22:10

Or if you can't use Anvil, ask someone who can to copy/paste something in it for you.

(I can't use Anvil any more or I'd offer myself).
User avatar

Pfhorrest
California

Post Mar 8th '14, 12:07

Thank you very much for feedback guys! Hopefully, that will be addressed in the next ShapeFusion :)

Luckily, I'm able to use Anvil under a MacOS Classic emulator, so once I'll try that out, I'll report on success!
User avatar

EinhanderZwei
Nikolaev, Ukraine

Post Mar 8th '14, 20:14

Which OS are you running ShapeFusion in?
User avatar

treellama
Pittsburgh

Post Mar 9th '14, 04:13

treellama wrote:Which OS are you running ShapeFusion in?

I'm using Windows XP SP3
User avatar

EinhanderZwei
Nikolaev, Ukraine

Post Mar 9th '14, 13:20

Hopper sent me a patch that might help. Please let me know if this works better for you.
Attachments
ShapeFusionLandscapeFix.zip
(2.61 MiB) Downloaded 119 times
User avatar

treellama
Pittsburgh

Post Mar 14th '14, 10:01

I'm so sorry for the long delay; was too busy with personal stuff lately... but hey, I've finally tried the fixed version, and it worked perfectly!! I've imported a bitmap, and it was properly displayed in Visual Mode!

Thank you so much! :)
User avatar

EinhanderZwei
Nikolaev, Ukraine

Post Mar 14th '14, 12:31

Great, thanks! We'll make sure the fix makes it into the next build.
User avatar

treellama
Pittsburgh

Post Mar 12th '15, 00:05

I've actually been having the same issue with the landscapes. Even trying to revert them back to normal doesn't work.

Is there an OSX version of that fix you provided, Treellama? Thanks in advanced.
User avatar

Hathomirr
The Void


Return to Editors, Emulation, Etcetera



Who is online

Users browsing this forum: No registered users