Thank God it's you!

Introduce yourself here!

Thank God it's you!

Post Oct 3rd '19, 05:38

Hi! I have been browsing these pfhorums these last couple of weeks. Now I have found that I have need of them. Is there possibly a thread about getting Rubicon X working on Linux with the latest beta? And what times are most people playing multiplayer? I have been getting a hankering for older multiplayer games, and I haven't actually tried the multiplayer in this yet. I was rewarded for it quite handily when I tried the multiplayer in Duke Nukem 3D: Megaton Edition, which made me realize the *magic* of dueling! How fun. I die most of the time, but it's impossible not to have fun. And it caused me to seek out some more arena FPS, which led me to Xonotic. Xonotic is great.

I wonder if I am different from most of you. The entire trilogy was released before I was even born in 1997, but my father liked these games (among other classics), and as I grew up, he introduced me to playing them via Aleph One. Now I'm in college, and the other day when I was blasting my way through Infinity on a whim, I had an amusing thought that I might be playing games in college that *he* might have been playing around this time.

It is heartwarming to see people still in these communities. It is even more heartwarming that I'm able to post right now! Why, duke4.net? Why?!
Tooncinator

Post Oct 3rd '19, 08:07

Aloha! That's neat to think that Marathon has become an intergenerational game! And also depressing to think about because it's a reminder that I'm old enough to have kids old enough to play games that I played when I was a kid.

What sort of problems are you having with Rubicon X on Linux? A disproportionately large amount of us here, including myself, use Linux, and I haven't heard of any problems.

Multiplayer games these days are mostly coordinated on the Discord:
https://discord.gg/R8PvSwh
Beware, it is not a healthy place.

Most people just do Infinity netgames, but you could get lucky.
User avatar

ravenshining
Hawai'i

Post Oct 4th '19, 01:21

Hello! Already I see fruits of my making an account here! Thank you for the invite to the Discord. Indeed, I was planning on using Infinity to play it. I've never beaten Rubicon X, though.

Alright, I will tell you of my problems, but be warned, they are probably extremely simplistic. I haven't been using Ubuntu for very long and I still make a bunch of incredibly stupid mistakes.

I am mostly confused by the requirements listed on the website -- I see no folders for "Fonts" or "Themes" in any Aleph One build I've seen. In addition, dropping the executable into the folder doesn't make much sense to me, seeing as there is no executable in any of the other Marathon games... I launch those by pointing the executable from /usr/local/bin/AlephOne to the directory of the Marathon games. But with Rubicon X, I'm not sure where exactly to point it. There's a data folder and a MacOS folder and I don't know whether to dip into the "Data" folder or not. Anyway, on to the error.

This is what runs, pretty predictably I think I have the data either misplaced or missing or perhaps I am not pointing the executable correctly.

/usr/local/bin/alephone ~/Games/MarathonGames/RubiconX/"Rubicon Data"
Aleph One Linux 2019-03-31 1.3b3
https://alephone.lhowon.org/

Original code by Bungie Software <http://www.bungie.com/>
Additional work by Loren Petrich, Chris Pruett, Rhys Hill et al.
TCP/IP networking by Woody Zenfell
Expat XML library by James Clark
SDL port by Christian Bauer <Christian.Bauer@uni-mainz.de>

This is free software with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
For details, see the file COPYING.

Built with network play enabled.

Built with Lua scripting enabled.
while initializing preferences (preferences.cpp:2939)
fatal alert (ID=-1): Please be sure the files 'Map', 'Shapes', 'Images' and 'Sounds' are correctly installed and try again. (csalerts_sdl.cpp:210)

That's pretty much it. How do you install Rubicon X, where do you find "Fonts" and "Themes", where do you put them, and what script are you running?
Tooncinator

Post Oct 4th '19, 04:23

Sounds like you've got some terrible directions.

You're right, the correct way to launch a scenario in Linux is to point the executable in /usr/local/bin (which shouldn't require typing out, I just enter alephone scenariopath/ into the terminal) to the scenario folder. Anything telling you to put an appl or exe in the scenario folder is meant for Mac or Windows and should be ignored.

With the latest 1.3 beta of alephone, all you should need to do is, without any modification, run alephone on a fresh unzip of the scenario. I have had trouble with older betas complaining of misssing shapes/sounds/map etc. when it actually needed a theme, in that case, just plop any theme plugin into Rubicon/Plugins/, ~/.alephone/Plugins/, or even /usr/local/share/AlephOne/Plugins/.

It's also possible that the scenario's MML is messed up - I think that stupidly, different platforms require different syntax for MML to find certain files correctly. Look in Rubicon/Scripts/Filenames.mml to make sure everything is consistent with where things are, how they are spelled, and case sensitivity.

If you want a GUI way of running A1, depending on your DE, you may find it useful to associate directories with alephone, so you can either right click on a folder and open it with A1; then, either create a shortcut (called a "desktop configuration file" in KDE) for alephone that you can drag a folder onto to start, or create per-scenario shortcuts to run the equivalent terminal command.
User avatar

ravenshining
Hawai'i

Post Oct 4th '19, 08:17

Huh. It now works. I just started over, unzipped it, and now the command works. Sorry for making you type all that out, but I might not have even tried it without attempting to follow your directions. So thank you! And now I know that the alephone command works, in addition to your troubleshooting in case more scenarios get borked in the future. I have a little folder that contains shell script shortcuts to any games that I would normally have to dip into the command line to run.

If you were wondering, I was attempting to follow the instructions on the http://www.marathonrubicon.com/ site. They mentioned that you had to drop "Fonts" and "Themes" into the folder, so I was trying to troubleshoot *that*. I guess I hadn't tried just launching the darn thing without changing anything.

I also have you to thank for my first batch of network games - I even won one round!
Tooncinator


Return to Welcome



Who is online

Users browsing this forum: No registered users

cron