(Tech Help) Can't get any Aleph 1 scenario to run on Macbook

Have a question, suggestion, or comment about Aleph One's features and functionality (Lua, MML, the engine itself, etc)? Post such topics here.

(Tech Help) Can't get any Aleph 1 scenario to run on Macbook

Post Nov 3rd '19, 19:02

I have a 2017 Macbook Pro. Anytime I try to run any downloaded scenario it just shows a black screen for a sec then crashes.

Tried following suggestions here: https://github.com/Aleph-One-Marathon/a ... /issues/57

But nothings works.

Reducing the resolution causes the issue to change so that now a black screen shows on startup but then nothing happens and I am forced to hard reset my machine because it wont even let me cmd+tab or force quit.

The closest I got to a working game was setting "scmode_auto_resolution" to false in the preferences. That got the game to go to the home screen however, all of the buttons save for the Aleph 1 info button the the bottom corner were completely non functional.

Getting desperate and any help would be appreciated.

Post Nov 4th '19, 23:15

This topic might help.
Or give you some clues of other words to search the Pfhorums with.
I got this result, inter alia, by searching: black screen
I'd like to be of more help, but I really don't know anything about the Mac system & operation.
Actually, I'm still not completely convinced that PC's aren't just magic in a box.
I just play 'em; I don't know how they work.
User avatar


Post Nov 5th '19, 04:22

It seems the solution is to reduce the display resolution to as low as possible. Works for me!

Return to Aleph One Discussion

Who is online

Users browsing this forum: No registered users