problems using controller on PC

Have a question, suggestion, or comment about Aleph One's features and functionality (Lua, MML, the engine itself, etc)? Post such topics here.

problems using controller on PC

Post Dec 4th '19, 20:26

I've never tried using controllers on a PC, so I may just be doing something stupid, or NOT doing something obvious to the rest of you, but...trying to get this working on a friend's PC. It's a TTX Tech "Universal USB controller", styled as a PS2/3 controller.

It DOES seem to work with the other game we tried, an emulator I think it was, and it worked fine. I found the thing in Windows device manager, too, and all the buttons and sticks act just like I'd have expected.

So is there anything special we need to do to get a controller to work with Aleph One? He has Windows 10, and the newest version of AO as of about 2 months ago. I'm pretty sure that means

Post Dec 7th '19, 03:23

I think the newest version is 2019.3.31 and the one just before that is 2018.10.6

Try here
I just play 'em; I don't know how they work.
User avatar


Post Dec 11th '19, 20:09

Hmm...I guess I thought Aleph One was maintained by, now I'm guessing otherwise. In any case, thanks for the reply, I'll try that next time I'm over. *crosses fingers...

Post Dec 12th '19, 19:07 is the public-facing home of Aleph One, but GitHub is where the development happens. The newer build is a beta, so is not the main download listed on yet.
User avatar


Return to Aleph One Discussion

Who is online

Users browsing this forum: No registered users