screen keeps rotating

Have a question, suggestion, or comment about Aleph One's features and functionality (Lua, MML, the engine itself, etc)? Post such topics here.
Post Reply
JoeKool82185
Born on Board
Posts: 17
Joined: May 22nd '12, 01:26
Contact:

I'm not sure if this is Aleph One or my computer, but I'm wonder if you guys can help shed light on this situation I'm having.

Whenever I play Marathon Infinity, the prologue level, I get to the part where you go underwater and there are S'pht Compilers there. As I'm fighting the Compilers, the screen flickers and rotates. It literally rotates 90 degrees. And it's not just the game, but it stays like that when I go to my desktop as well. The entire computer is turns! I know Infinity is supposed to be the one that plays with reality, but this is a bit too fourth wall breaking for me.

I'm using an Xpadder gamepad to play, and I have the swim button mapped to Left Ctrl, the right trigger mapped to Space, and I believe the left trigger is Tab (I'm fist fighting the Compilers underwater). Is that it, or is there a problem with Aleph One? Are those buttons part of a shortcut for screen rotation? WHY THE FUCK WOULD THE COMPUTER EVEN ALLOW YOU TO ROTATE THE SCREEN!? And how do I prevent this from continuing? This is a game-breaking bug that's pretty much keeping me from enjoying this game.
User avatar
Zott
Vidmaster
Posts: 1659
Joined: Jul 1st '06, 21:14
Location: Earth
Contact:

Intel GPUs have a built-in screen rotating hotkey.
As this link explains, it is Alt-Crtl-Arrow Key
http://www.wikihow.com/Literally-Rotate ... ter-Screen

This is probably the key combination being triggered.

You can try disabling the hotkey in Intel's Graphics options.
Other GPUs have screen rotation capabilities, but to my knowledge they are not mapped to a hotkey.
Post Reply