Widescreen?

Have a question, suggestion, or comment about Aleph One's features and functionality (Lua, MML, the engine itself, etc)? Post such topics here.
Post Reply
D88M
Spazeroid
Posts: 2
Joined: Sep 9th '19, 02:24

Sorry if this is a dumb question, but i just got Aleph One again after a while and i cant figure out of how to make the screen look stretched, the game looks in 4:3 format for some reason no matter what i put on the options menu, any solution?
User avatar
The Man
Vidmaster
Posts: 1112
Joined: Aug 6th '08, 05:23
Location: Sarasota, FL
Contact:

Depends what you’re looking for (“make the screen look stretched” is a bit vague). If you want the XBLA appearance, there’s a plugin for that which can be enabled or disabled for the trilogy, as well as some scenarios (preferences → environment → plugins → the plugin name will vary). If you don’t want that, but your HUD is taking up 1/3 of the screen and you just don’t want that, then go to preferences → graphics → HUD size and change it from “largest” to “double” or “normal”, depending on your taste. It’s also possibly a result of preferences → graphics → screen size; you might’ve selected a 4:3 aspect ratio there, I suppose.
“People should not be afraid of their governments. Governments should be afraid of their people.” —V, V for Vendetta (Alan Moore)

“The trouble is that we have a bad habit, encouraged by pedants and sophisticates, of considering happiness as something rather stupid. Only pain is intellectual, only evil interesting. This is the treason of the artist: a refusal to admit the banality of evil and the terrible boredom of pain. If you can’t lick ’em, join ’em. If it hurts, repeat it. But to praise despair is to condemn delight, to embrace violence is to lose hold of everything else. We have almost lost hold; we can no longer describe happy man, nor make any celebration of joy.” —Ursula K. Le Guin, “The Ones Who Walk Away from Omelas”

“If others had not been foolish, we should be so.” —William Blake, The Marriage of Heaven and Hell

“The law cannot protect anyone unless it binds everyone; and it cannot bind anyone unless it protects everyone.” —Frank Wilhoit

Last.fm · Marathon Chronicles · Marathon Eternal 1.2 · Where Monsters Are in Dreams · YouTube Vidmaster’s Challenge
User avatar
ravenshining
Vidmaster
Posts: 889
Joined: Jun 17th '17, 22:50
Location: Hawai'i

Which scenario are you playing, and with which HUD?

If you're playing M1 with the default HUD, you can only play in 4:3 because the game sits inside the HUD. To play M1 in other resolutions, use the floating HUD or the M1A1 HUD. M1R currently only has the latter available.

If you're playing M2 or M∞ with the default HUD, or some flavour of M1 with the M1A1 HUD, or a third-party scenario with no HUD plugin, then you will be locked to 4:3 if you have "HUD size" set to "Largest" in your graphics preferences. Set HUD size to Normal or Double to allow wider views. In this HUD mode, the world is rendered in a 2:1 frame and the HUD is placed below it, so the smaller the HUD the more space you have to display the world.

If you're playing any scenario with a floating HUD, you should be able to play at any normal resolution, but some extreme resolutions like 3:1 will require editing the HUD script to enable this.
D88M
Spazeroid
Posts: 2
Joined: Sep 9th '19, 02:24

Thanks for the answers people, what i did was change the resolution to 1360x768 to 1024x768 with "fill the screen" on within Marathon Durandal and Infinity, while i did the same thing but with "fill the screen" off for Marathon 1, and it just worked, is not perfect but whatever, i can play it better now.
Post Reply