Page 1 of 1

Linux install help

Posted: Sep 11th '20, 19:30
by data-angel

Code: Select all

checking for SDL - version >= 1.2.0... yes
checking SDL_ttf.h usability... no
checking SDL_ttf.h presence... no
checking for SDL_ttf.h... no
configure: error: You need SDL_ttf to run Aleph One.
It's all installed like it says but uh.. this??? What do I do about this?

It's present in these places:

Code: Select all

/usr/lib/x86_64-linux-gnu/libSDL_ttf-2.0.so.0.10.1
/usr/lib/x86_64-linux-gnu/libSDL_ttf-2.0.so.0
/usr/share/cmake-3.10/Help/module/FindSDL_ttf.rst
/usr/share/cmake-3.10/Modules/FindSDL_ttf.cmake
/usr/include/SDL2/SDL_ttf.h
Where is it supposed to be for this to read it?

Re: Linux install help

Posted: Sep 11th '20, 20:01
by TBCR
Which distro are you running on?

Re: Linux install help

Posted: Sep 11th '20, 20:08
by data-angel
Linux Mint 19.3 @TBCR

Re: Linux install help

Posted: Sep 17th '20, 21:14
by Tooncinator
I think I helped you nearly a year ago. You should come back to the Discord for some install help. Writing forums posts is soooo lame.

Re: Linux install help

Posted: Sep 24th '20, 20:38
by TBCR
Can you confirm if any additional packages ask to be installed after running the following command:

$ sudo apt install '^libsdl2-*'

Re: Linux install help

Posted: Sep 27th '20, 11:49
by herecomethej2000
Alephone uses SDL2 now I believe, if SDL2 is what you intend to use you'll need libsdl2-ttf.


libSDL_ttf-2.0 is the 2nd version of SDL1.2's library