Weland Doesn't Start

Questions about the content creation procedure go here, including using Forge, Anvil, or other editors, or operating emulators like Basilisk II.
Post Reply
User avatar
Zott
Vidmaster
Posts: 1659
Joined: Jul 1st '06, 21:14
Location: Earth
Contact:

I am having difficulty coaxing Weland 1.4.1 to start. Upon double clicking the .exe the computer churns for a while with the waiting cursor, then politely closes Weland out without a message. Trying the earlier Weland versions as far back as 1.1.2 give crash messages upon startup but otherwise fair no better.

I have installed both Mono 3.2.3 and 2.10.X to no change, as well as .NET 4.5 and its updates. It used to work fine, so I am not sure what has brought about this issue. The log seems to implicate .NET so I'll try and work around there some more, but running out of ideas. Thoughts?

Computer Specs:
Windows 7 x64 Premium
2.26GHz P8400
Nvidia 9700m gt @ 1680 x 1050
4GB RAM


Windows Event Message:
Application: Weland.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.DllNotFoundException
Stack:
at GLib.Object.gtksharp_register_type(IntPtr, IntPtr)
at GLib.Object.RegisterGType(System.Type)
at GLib.Object.LookupGType(System.Type)
at GLib.Object.LookupGType()
at GLib.Object.CreateNativeObject(System.String[], GLib.Value[])
at Gtk.Widget.CreateNativeObject(System.String[], GLib.Value[])
at Gtk.DrawingArea..ctor()
at Weland.MapDrawingArea..ctor()
at Weland.MapWindow..ctor(System.String)
at Weland.Weland.Main(System.String[])
User avatar
treellama
Vidmaster
Posts: 6107
Joined: Jun 2nd '06, 02:05
Location: Pittsburgh
Contact:

You need to install GTK#. See the Weland README for install instructions.
Post Reply