Page 1 of 1

Issue with Vasara 1.0.2 (string Solo Lua...)

Posted: Jan 20th '16, 02:14
by Neonstar
Hello all. Whenever I open any map in vasara (I've tried my own, and Durandal's normal maps) Vasara's interface doesn't display and it's features don't work. In the top left of the game screen I get a print out as follows:

[string "Solo Lua"]:1012: attempt to index field '_freeze' (a nil value)
[string "Solo Lua"]:1819: attempt to index field '?' (a nil value)
[string "Solo Lua"]:1012: attempt to index field '_freeze' (a nil value)
[string "Solo Lua"]:1819: attempt to index field '?' (a nil value)
[string "Solo Lua"]:1012: attempt to index field '_freeze' (a nil value)
[string "Solo Lua"]:1819: attempt to index field '?' (a nil value)
[string "Solo Lua"]:1012: attempt to index field '_freeze' (a nil value)

(end of the above)

If I disable solo scripts in preferences, this issue happens. If I enable solo scripts but don't select one, Vasara simply just doesn't even load. Does anyone know of this issue, or how to solve it?

EDIT: Turns out this is what happens if you don't remove Infinity exclusive content from Vasara's scripts when running with Durandal.

Re: Issue with Vasara 1.0.2 (string Solo Lua...)

Posted: Jan 20th '16, 12:30
by Crater Creator
It sounds like there's some confusion between solo scripts and plugins. Vasara is meant to be run as a plugin. Try enabling the one or two Vasara plugins (depending on how old your version is), and disabling all other plugins. Turn off Solo Script, too. Then let us know the results.

Re: Issue with Vasara 1.0.2 (string Solo Lua...)

Posted: Jan 20th '16, 23:43
by Neonstar
I have Vasara loaded as a (single, latest version) plugin. I thought maybe it was a version issue, but I can't find older version downloads anywhere to test it out, and my original Windows rig with all my mod stuff is at a repair shop at the moment. (Weland always crashed for me, but doesn't on Mac so I'm trying mapping again)

Re: Issue with Vasara 1.0.2 (string Solo Lua...)

Posted: Jan 22nd '16, 03:03
by Hopper
As stated in the Read Me, the stock Vasara is compatible with Infinity but not Durandal. You need to edit lines 7-8 of Vasara Script.lua to remove the Infinity-only collections.

Re: Issue with Vasara 1.0.2 (string Solo Lua...)

Posted: Jan 22nd '16, 06:18
by Neonstar
Ah okay, I thought it would mean there would just be empty spaces in the texture list. I'll edit soon whether that fixes it.

EDIT: Fixed under Marathon Infinity,and I got it working in M2, thanks.

Re: Issue with Vasara 1.0.2 (string Solo Lua...)

Posted: Jan 23rd '16, 21:33
by Hopper
Cool, glad you got it working. Sorry it doesn't fail in a more understandable manner.

Re: Issue with Vasara 1.0.2 (string Solo Lua...)

Posted: Jan 24th '16, 18:41
by Hopper
Vasara 1.0.3 is out now, which mostly works with M2 out of the box. The fourth "landscape" is screwed up, because M2 uses that collection for something else, but otherwise it should be okay.

Thanks for trying Vasara, Neonstar!

Re: Issue with Vasara 1.0.2 (string Solo Lua...)

Posted: Jan 25th '16, 02:22
by Neonstar
I saw it and it works perfectly, thank you.