Page 1 of 1

Using custom Shapes with Forge

Posted: Aug 10th '16, 20:04
by lj6014
Be-pfhor I even start this post I don't want to hear a single post saying use Weland or some other modern editor, I use forge, End of story. I know this has been posted before but none of those post got any satisfactory answers and are filled with basically this "USE WELAND IDIOT, WAAAAAHHH"

Recently I have been interested in modifying the original Marathon Infinity Files such as shapes sounds and physics but have came across a bug, whenever I use forge with a different shapes file including the Marathon 2 Shapes I get this:

Sorry, a run-time assertion failed in "shapes.c" at line #1138. PLEASE WRITE THIS DOWN AND MAKE A BUG REPORT!

Any way to fix this/get around this? DON'T SAY WELAND! Any help will be much appreciated, Thanks.

Re: Using custom Shapes with Forge

Posted: Aug 10th '16, 20:17
by General Tacticus
I have been having a similar issue with my mapping project. In my case it is less consistent, and appears to be affected by the map as well. I think the error code is the same, though.

I would be interested in some insight here as well.

Re: Using custom Shapes with Forge

Posted: Aug 10th '16, 20:39
by Wrkncacnter
There's an assertion in line 1138 of shapes.c of the infinity source code, so you could poke around in there to try to figure out what might be causing the issue. It likely has a lot of shared code with forge.

Re: Using custom Shapes with Forge

Posted: Aug 19th '16, 23:04
by goran
lj6014 wrote:Be-pfhor I even start this post I don't want to hear a single post saying use Weland or some other modern editor, I use forge, End of story. I know this has been posted before but none of those post got any satisfactory answers and are filled with basically this "USE WELAND IDIOT, WAAAAAHHH"

Recently I have been interested in modifying the original Marathon Infinity Files such as shapes sounds and physics but have came across a bug, whenever I use forge with a different shapes file including the Marathon 2 Shapes I get this:

Sorry, a run-time assertion failed in "shapes.c" at line #1138. PLEASE WRITE THIS DOWN AND MAKE A BUG REPORT!

Any way to fix this/get around this? DON'T SAY WELAND! Any help will be much appreciated, Thanks.
Forge only works with infinity shapes files if I recall correctly. M2 shapes do not include the necessary jjarro collection.

You also have the issue of missing header files. If the shapes file has gone through windows the header will be missing. There is a software called ResEdit that you can use to access and edit the header information.

Re: Using custom Shapes with Forge

Posted: Jun 10th '18, 17:49
by lj6014
yeah this is awhile later, but I finally got it to work, don’t know what I was doing wrong though

Re: Using custom Shapes with Forge

Posted: Jun 11th '18, 00:11
by HelviusRufus
lj6014 wrote:...but I finally got it to work...
good news.
per aspera ad astra.