Page 1 of 1

weland 1.4.5

Posted: Oct 27th '20, 16:35
by treellama
Weland 1.4.5 has a new feature I call Visual Mode. Basically, you can go into the Weland preferences, choose an Aleph One executable (1.4 or higher required, preview build linked below), and a scenario, and then "Edit Preferences". Configure your controls and choose the Lua visual editor of your choice (Visual Mode.lua or Vasara) then quit Aleph One. From now on, when you choose Visual Mode from the view menu, Weland will start up Aleph One directly into editing mode, and Aleph One will automatically export the changes back to Weland when you exit the level.

Try it out! ... e-20201026

Re: weland 1.4.5

Posted: Oct 28th '20, 00:21
by The Man
This is, no joke, one of the best things to happen to this engine in years. Thanks so much for all your hard work.

Re: weland 1.4.5

Posted: Nov 12th '20, 06:09
by BlackMageAnolis
Trying to get both this and 1.4.4 running, but neither are starting up. The thing is I was able to start Weland up last time I worked with it, so I don't really know what's up now.

Edit: Well, I guess all I really needed to do was redownload the .NET and GTK# packages. - < - Though now I'm not able to get Visual Mode to work. It borked out on me saying:
Cannot start process because a file name has not been provided.
at System.Diagnostics.Process.Start()
at Weland.MapWindow.VisualMode()
at Weland.MapWindow.OnViewMenu(Object obj, EventArgs args)
I don't know if this means the name of the map file or the name of an Aleph One executable. I even tried to fiddle with preferences to get the "Aleph One" directory to the actual directory that I have on my computer, but it doesn't seem to stick. (It wants to go into the Image Cache, which is very annoying.)

Edit 2: That error isn't showing up, but now it's frozen on "Entering Visual Mode". I had Visual Mode working when I last worked with Weland, but now it seems borked. I know you have to put the plugin within the scenario itself, but would you also need to do it within Weland plugins?

Edit 3: Using Visual Mode through Aleph One directly. The only problem is the wall textures aren't saving when I apply them. Still not able to use Visual Mode through Weland itself. Set "Aleph One" to the Marathon 2 executable and "Scenario" to the folder it's in. It throws out this error when I try and do it in Weland:
Could not find file 'C:\Users\******\AppData\Local\Temp\97714310-2449-43ff-bdcf-0e062c512a0c.sceA'.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
at Weland.Wadfile.Load(String filename)
at Weland.MapFile.Load(String filename)
at Weland.MapWindow.<VisualMode>c__AnonStorey2.<>m__1(Object , EventArgs )
at Gtk.Application.InvokeCB.Invoke()
at GLib.Timeout.TimeoutProxy.Invoke(IntPtr data)
at GLib.SourceProxy.HandlerInternal(IntPtr data)

Re: weland 1.4.5

Posted: Nov 12th '20, 12:07
by The Man
“Shapes File” is probably self-explanatory.

In my setup, I have “Aleph One” pointing to “F:\Games\AlephOne-20201026\AlephOne64.exe”. You’ll want to select whatever your executable file for Aleph One is. It has to be 1.4pre1 or a later build.

For “Scenario”, I’ve selected “C:\Users\Aaron\Dropbox\WMAiD Aleph One 2020-07-26”. Whatever directory you select, you want it to be a directory that you’d be able to drag and drop onto AlephOne64.exe and simply play the game. So for Marathon Infinity, it’d be the root folder containing the shapes, sounds, map, and so on. A couple of scenarios (I’m looking at you, Rubicon) do this differently, annoyingly enough. If you can’t drag and drop the folder onto the Aleph One app, it’s the wrong folder.

Once you’ve got those working, you’ll want to select “Edit Preferences”, and set up Vasara or VML within the game preferences to suit your taste. This will establish a completely separate preferences file, so you’ll probably have to reset your keystrokes and whatever else you want. Once you’ve done that, quit out of Aleph One. I would also recommend quitting out of Weland and then restarting your machine. This may not be necessary, but it can’t hurt.

I got that unhandled exception for a while too, and then it just stopped appearing. I thought it might’ve been caused by using files on different drives, but having looked at my preferences again, that’s obviously not the case. It’s possible that just restarting the computer was the cause. It’s also possible that I had a copy of one of the files open, and that Weland didn’t like that.

If you’re running the plugins through Aleph One directly, you need to type

Code: Select all

.save level
into the console (accessible by pressing “\”), which will save a copy of the map in (assuming you’re using Windows 7 or later) “C:\Users\username\Documents\AlephOne”. I don’t recommend doing it this way, because it sucks. If you can get Weland’s Visual Mode working properly, it’s better by far.

There are a few things that still don’t save properly. Platforms should be in the same place they’re supposed to start the level; some of them will suffer texture misalignments otherwise (split doors are especially notorious for this; I think everyone has this happen to them several times a year if they edit maps at all). Tag switches (including wires and chip insertion switches) also won’t save properly if they differ from the state in which they start the level. The best way I’ve found to restore them to their initial state is in the console, using one of:

Code: Select all


Code: Select all

and replacing “x” with the proper tag number. If you don’t reset tag switches to their initial state, wires and chip insertion switches in particular may not work properly.

The only other thing I can think of is to make sure you’ve got the proper version of GTK# installed.